Troubleshooting: SharePoint 2010 não desconecta da Farm automaticamente

  

Olá SharePointianos,

Desde o lançamento público em versão Beta do SharePoint 2010, muitos clientes da minha empresa tem solicitado pilotos de projetos utilizando o produto, possivelmente motivados por alguma apresentação ou mesmo após testarem a nova plataforma que sem dúvida evoluiu muito desde sua versão atual (2007).

Em um desses ambientes pilotos, onde estamos implantando para efeito de avaliação o SharePoint 2010, um dos meus clientes solicitou que eu instalasse a versão Foundation do Sharepoint 2010 e depois solicitou um upgrade desse ambiente para o Sharepoint Server 2010 para testar as diferenças das funcionalidades na prática…

Analisando que o Foundation é a base da arquitetura do Server, pensei que instalar o Server iria apenas atualizar a versão do SharePoint e adicionar as features do produto… Correto?

Não deveria… Imaginem que em nosso mundo cruel e perfeccionista de TI que vivemos, uma só vírgula fora do lugar, gera um enorme caos e problemas imensuráveis. Pois é, sabendo disso, sem dúvida com a experiência que tenho o melhor caminho seria no minimo:

1.       Backup do meu ambiente

2.       Desinstalação COMPLETA do ambiente Sharepoint Foundation 2010

3.       Instalação NOVA do SharePoint Server 2010

4.       Restore do ambiente

Lições aprendidas, acreditem, meu atalho não funcionou, traçando o caminho mais perto, demorei mais para alcançar o meu destino. Vejam..

Cenário:

Portal piloto em SharePoint Fondation 2010, utilizando recursos básicos como Listas Customizadas, Blogs, algumas WebParts personalizadas, Workflows entre outros recursos simples…

Objetivo:

Migrar o ambiente atual para utilizar recursos “Enterprise” como Performance Point, Fast, Blog Corporativo, Wiki Corporativo, BCS, entre outros.

Solução Adotada:

Instalação “overwrite” do SharePoint Server 2010 no ambiente existente em SharePoint Foundation 2010.

Resultado:

Alguns recursos não funcionaram como deveriam, o que nos gerou obviamente a dúvida se a causa era a instalação de “overwrite”.

Nesse caso, desinstalei o SharePoint Server 2010 e o Foundation (acredite, os 2 ficaram instalados na máquina), depois desinstalei o SQL.

Logo em seguida instalei o SharePoint Server e o SQL novamente, tudo bem sucedido. J

Ao tentar executar o SharePoint 2010 Products Configuration Wizard

ERRO:

No primeiro passo do SharePoint Configuration Wizard já era apresentado erro e iterrompia sua execução, a mensagem de erro apresentada era:

                Configuration Failed

                Failed to connect to the  configuration database.

Login Failed for “UserName”.

Ou seja o acesso era negado no SQL Server, mas ao analisar o SQL, meu usuário atual tinha acesso ao banco e pior, analisando o log, verifiquei que o Configuration Wizard tentava se conectar a um database que já não existia mais… #Fail

O pior de tudo é que o Configuration Wizard não apresentava a opção de desconectar do Farm… E agora?

SOLUÇÃO:

Após tentar limpar todos os registro dessas instalações mal sucedidas tanto do SQL como do SharePoint e constatar que nada funcionava, tentei manualmente configurar uma nova farm para minha instalação SharePoint Server 2010…

Para isso executei os seguintes passos:

1.       Instalei o SharePoint Server 2010

2.       Instalei o SQL Server 2008

3.       Criei manualmente um novo database.

4.       Executei a operação setconfigdb via STSADM para configurar meu novo Config Database criado acima, veja mais sobre setconfigdb em: http://technet.microsoft.com/en-us/library/cc261712.aspx  

 

Ex.: stsadm -o setconfigdb -databaseserver “SERVERSQL” -databasename “SharePoint_Config” -farmuser “DOMAINUser” -farmpassword “@@Senha@@”

Assim funcionou!

Após esses passos exeutei o Configuration Wizard e o SharePoint foi configurado corretamente na minha nova database. J

Seguem alguns links interessantes que encontrei nessa minha jornada:

10 Tips Troubleshooting Installations for SharePoint 2010 and SharePoint Foundation
http://www.sharepointjoel.com/Lists/Posts/Post.aspx?ID=280  

 

Upgrade and Migration Resource Center for Microsoft SharePoint Foundation 2010 (Beta)
http://technet.microsoft.com/en-us/sharepoint/ee517215.aspx

 
Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s


%d blogueiros gostam disto: