Archive for maio \25\UTC 2009

Visual Studio 2010 e .NET Framework 4 Beta 1

25 de maio de 2009
Olá Pessoal,
 
Está disponível para download tanto o VS 2010 como o Framework 4 Beta 1.
 
Abaixo segue um link para download e informações dos 2 produtos:
 
Visual Studio 2010 and .NET Framework 4 Beta 1
 
O Bruno Velaz postou algumas informações interessantes em seu Blog do Canal SharePoint sobre esse lançamento e as novidades que isso traz para nós SharePointers, recomendo a leitura.
::Relases 2010:: Novo Visual Studio 2010 e .Net Framework 4.0 – E as novidades com SharePoint
 
Abraços e bons testes!

Novo Blog – Canal SharePoint

12 de maio de 2009
Pessoal,
 
Quero aproveitar esse espaço para divulgar meu novo Blog, disponibilizado no site Canal SharePoint, uma das maiores comunidades virtuais da América Latina focada nos produtos e tecnologias SharePoint.
 
Fica também a dica, após um período "fora do ar", ocasionado pela indisponibilidade em servidores que hospedavam o site, estamos investindo muito na criação e disponibilização de informações sobre a tecnologia, novidades como vídeos de um "RoadMap de Desenvolvimento em WSS 3.0" estão sendo concluídas e em breve teremos muita coisa bacana, acompanhem, já temos um bom número de tutorias, modelos de aplicativos, entre outras informações, confiram…!
Abraços

Troubleshooting: HTTP/1.1 404 Connection: close Date: GMT Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET MicrosoftSharePointTeamServices: 12.0.0.6219

6 de maio de 2009
Pessoal,
 
Vai um post de Troubleshooting bem rápido, pois acho que algumas vezes já me deparei com esse erro.
 
Esses dias tive a necessidade de implantar o "Infrastructure Update" (http://support.microsoft.com/kb/951695) em uma aplicação que roda no WSS 3.0 + SP1. Até ai legal, implantei o update no ambiente de deenvolvimento, mesmo assim após alguns backups, porque já conhecia a fama hehehe.
 
Enfim, por N motivos que talvez eu poste aqui em breve, esse update "desconfigurou" minhas aplicações existentes e então aparecia o erro "HTTP/1.1 404 Connection: close Date: GMT Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET MicrosoftSharePointTeamServices: 12.0.0.6219", que é o foco desse post…
 
Vamos lá, esse erro na verdade é gerado quando tentamos acessar um site que não possui uma Site Collection vinculada a Web Application existente, ou seja, de forma simples, no endereço que está tentando acessar o site, o IIS reconhece uma Web Application do SharePoint porém quando o SharePoint vai carregar o site, não existe "Site Collection" associada, entederam? Bommm, o ponto é que principalmente se esse erro ocorrer em uma aplicação que já existia, verifique a associação da Web Application com a Site Collection, no meu caso eu tive que refazer essa associação na unha :|.
 
É isso ai galera, não posso me aprofundar nesse Troubleshooting porque realmente as coisas estão bem corridas, mas qualquer dúvida, comentem ai que eu tento ajudar.
 
Abraços!!